off220 28.12.2010 08:34

Есть проблема!Arch,Xorg,intel,vga

Доброго всем времени. Столкнулся с проблемой, решить которую не могу, надеюсь на вашу помощь :)
В общем: есть комп Intel i3 с интегрированной intel же видеокартой. Есть монитор viewsonic VA2413wm на котором только vga. Есть свежий Arch, с последними обновлениями. Установлен xorg, gnome, xf86-video-intel. Нет нормального разрешения 1920х1080.

Есть логи xorg (переделал старый с nvidia) http://pastebin.com/gaCCUXZ4
Есть логи БЕЗ xorg (разрешение 800х600 ставится) http://pastebin.com/La9KZHRv

Ситуация: если создать xorg.conf или /etc/X11/xorg.conf.d/10-monitor.conf и в нем указать modeline из старого xorg или gtf 1920 1080 60 и вписать в него,
Section "Monitor"
Identifier "Monitor0"
Modeline "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync
EndSection

Section "Device"
Identifier "Device0"
Driver "intel"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1920x1080_60.00"
EndSubSection
EndSection
то изображение сплюснуто, хотя
1
2
xdpyinfo | grep 'dimensions:'
dimensions: 1920x1080 pixels (508x285 millimeters)


говорит, что разрешение наше. Если в xorg дописать Hsync и Vrefresh из спецификаций монитора - выставляется разрешение 1600х1200 (Allocated new frame buffer 1600x1200 stride 6656, tiled)
В чем может быть проблема?


Тэги: arch intel vga xorg
+ 1 -
Похожие Поделиться

derfenix 28.12.2010 08:48 #
Когда изображение сплюснуто, кнопочку автонастройки на мониторе не нажимал?
off220 28.12.2010 09:30 #
оно жестко сплющено. автонастройка не поможет.
derfenix 28.12.2010 14:51 #
так ты пробовал или нет?..
всякое бывает, у меня тоже было, что изображение на полэкрана было только и автонастойка растягивала его назад.
blackraven 28.12.2010 10:36 #
Я че-то не понял - монитор-то широкоформатный? А то 1600х1200 - ни разу не широкоформатное разрешение. С чего вы взяли, что монитор должен в 1920х1080 работать?
Мой широкоформатник держит 1920х1200, например. Думаю, у меня тоже было бы изображение сплющено, поставь я ему 1920х1080 :)

Марку монитора и спецификации в студию.

PS а еще я когда-то слышал, что через VGA-разъем разрешение большее, чем 1600х1200 передавать, - не сильно хорошая идея.
blackraven 28.12.2010 10:38 #
Упс. Туплю - не заметил указания марки монитора. Он и правда 1920х1080... Странно.
Shtsh 28.12.2010 11:41 #
В последнее время как-то часто сталкиваюсь с глюками при подключении мониторов через VGA.
Попробуй это

Section "Device"

блаблабла ......................

Option "IgnoreEDID" "1"
Option "UseEDIDFreqs" "0"

EndSection


off220 28.12.2010 12:17 #
Жесть. Заменил VGA шнур и все работает. Всем спасибо и с наступающим!!