kmk 22.01.2016 14:51

Есть проблема!Забиваются логи с новым сетевым адаптером

Приветствую всех! Сегодня приобрел новый USB Wi-Fi Адаптор TP-LINK WN722N, на чипе Atheros AR9271.



Все замечательно работает, однако стали забиваться логи со страшной скоростью:

/var/log/kern.log
и
/var/log/syslog

Вот куски этих логов:

kern.log

Jan 21 20:46:39 kmkpc kernel: [ 377.742485] [] ath9k_wmi_cmd+0xdc/0x170 [ath9k_htc]
Jan 21 20:46:39 kmkpc kernel: [ 377.742490] [] ath9k_regwrite+0x57/0xd0 [ath9k_htc]
Jan 21 20:46:39 kmkpc kernel: [ 377.742496] [] ? ath9k_regread+0x41/0x60 [ath9k_htc]
Jan 21 20:46:39 kmkpc kernel: [ 377.742506] [] ar9002_hw_pa_cal+0x298/0x790 [ath9k_hw]
Jan 21 20:46:39 kmkpc kernel: [ 377.742515] [] ar9002_hw_init_cal+0xd3/0x550 [ath9k_hw]
Jan 21 20:46:39 kmkpc kernel: [ 377.742518] [] ? __udelay+0x23/0x30
Jan 21 20:46:39 kmkpc kernel: [ 377.742527] [] ? ath9k_hw_synth_delay+0x4c/0x50 [ath9k_hw]
Jan 21 20:46:39 kmkpc kernel: [ 377.742532] [] ?


syslog

Jan 21 20:40:35 kmkpc kernel: [ 11.836194] [] ath_hw_keyreset+0x10c/0x1e0 [ath]
Jan 21 20:40:35 kmkpc kernel: [ 11.836196] [] ? devres_add+0x38/0x40
Jan 21 20:40:35 kmkpc kernel: [ 11.836200] [] ath9k_cmn_init_crypto+0x3a/0x50 [ath9k_common]
Jan 21 20:40:35 kmkpc kernel: [ 11.836203] [] ath9k_init_device+0x30a/0x800 [ath9k_htc]
Jan 21 20:40:35 kmkpc kernel: [ 11.836206] [] ? _dev_info+0x2d/0x30
Jan 21 20:40:35 kmkpc kernel: [ 11.836210] [] ? ath9k_init_htc_services.isra.5+0x225/0x240 [ath9k_htc]


Оба лога переполнены записями о новом адаптере.

Отключил USB-адаптер удалил логи. Перезагрузил компьютер. Пару минут логи со старым адаптером почти не растут (единицы килобайт). Подключил USB-адаптер. Логи меньше чем за минуту по 90МБ. Отключил адаптер, сохранил и выложил логи.

Посоветуйте, что делать? Посмотрите, кто в этом понимает: ЛОГИ

Пока не выясню причину, спасаюсь периодическим обнулением:
1
sudo cp /dev/null /var/log/kern.log && sudo cp /dev/null /var/log/syslog



Тэги:
+ 0 -
Похожие Поделиться

dront78 24.01.2016 11:51 #
либо ядро старое и не поддерживает, либо драйвера собраны криво
если есть dkms пакет драйвера в штатном репозитарии - стоит использовать. на форума разработчиков поспрашивать можно. если нет - пересобирать надо руками после каждого обновления ядра в дистрибутиве
kmk 24.01.2016 19:42 #
Ядра "свисток" поддерживают старые и новые, несколько перепробовал. Драйвера переустанавливал вручную. Что интересно, старая версия Ubuntu 14.04.0 не засоряет логи с любыми ядрами... Все последующие засоряют. (Последняя актуальная 14.04.3 LTS.)

Продолжение темы на дружественном линукс-форуме.