pozadi 05.04.2011 09:32

Есть проблема!Внезапно начал тормозить x-org

Debian Squeeze
nvidia GT218 (драйвер 260.19.26), 6Gb, core i7

Предположительно все началось после установки firefox 4
Ставил по инструкции
Добавил репозиторий (deb http://mozilla.debian.net/ squeeze-backports iceweasel-4.0) и т.д.

Особенно тормоза проявляются при движении по меню - выделение пунктов меню отстает от курсора. Также тормозит при сворачивании/разворачивании окон, переходе с вкладки на вкладку, даже при вводе текста (в IDE) иногда. Вообщем при любых операциях прорисовки.

Еще характерная особенность что-то случилось с цветом кнопок, появилась какая-то светлая "коемочка":


тормозит и в compiz, и в metacity
metacity даже сильнее тормозит

glxgears показывает:
55578 frames in 5.0 seconds = 11115.568 FPS

Еще раз уточню, что было время когда все работало, но внезапно стало тормозить.

upd
Просто top:

и топ при активном сворачивании/разворачивании окна:


upd
glxinfo
/var/log/Xorg.0.log
/var/log/apt/history.log.1.gz, кусок с установкой firefox (icedove):

Start-Date: 2011-03-28 09:15:41
Upgrade: libnss3-1d:amd64 (3.12.8-1, 3.12.8-1+squeeze1)
End-Date: 2011-03-28 09:15:45

Start-Date: 2011-03-28 09:36:48
Commandline: apt-get install -t squeeze-backports iceweasel
Install: xulrunner-2.0:amd64 (2.0-1~bpo60+1, automatic), libmozjs4d:amd64 (2.0-1~bpo60+1, automatic), libxcb-shm0:amd64 (1.6-1, automatic)
Upgrade: libcairo2:amd64 (1.8.10-6, 1.10.2-1.1~bpo60+1), libpixman-1-0:amd64 (0.16.4-1, 0.21.4-2~bpo60+1), iceweasel:amd64 (3.5.16-6, 4.0-1~bpo60+1), libnss3-1d:amd64 (3.12.8-1+squeeze1, 3.12.9-2~bpo60+1)
Remove: iceweasel-l10n-ru:amd64 (3.5.15+debian-1)
End-Date: 2011-03-28 09:36:55

Start-Date: 2011-03-28 10:04:50
Commandline: apt-get upgrade
Upgrade: icedove:amd64 (3.0.11-1+squeeze1, 3.1.9-1~bpo60+1)
End-Date: 2011-03-28 10:04:54



Тэги: debian Firefox iceweasel x-org xorg тормоза тормозит
+ 2 -
Похожие Поделиться

_92 05.04.2011 09:36 #
у меня от дополнения для rss периодически тормозит ff4
Bad Habit 05.04.2011 09:46 #
Попробуй отрубить аппаратное ускорение в файрфоксе (Дополнительные - Общие - По возможности использовать аппаратное ускорение).

Или оно так же себя ведет, когда файрфокс не запущен? Что говорит top в эти моменты?
pozadi 05.04.2011 09:47 #
Я им вообще не пользуюсь, сижу в chrome всегда.
Bad Habit 05.04.2011 10:01 #
Нужен вывод glxinfo и логи apt (кусок, захватывающий момент до начала тормозов + установка файрфокса и то, что было после), ну и Xorg.0.log неплохо бы
pozadi 05.04.2011 12:08 #
добавил в пост
pozadi 05.04.2011 09:55 #
добавил top в пост
Lemures 05.04.2011 13:29 #
У меня тоже тормоза начались с прошлого четверга. Но фф4 я раньше установил. А в четверг ставил кучу обновлений, в том числе и ядро новое пришло. Подумал, что из-за этого. Поставил 35е ядро, чуть лучше стало, но тормоза всё ещё ощущаются.
Lemures 05.04.2011 13:33 #
Да, система Убунту 10.04, видюха 9800gx2 (260.19.44).
Вот список обновлений, до которых всё было ок:
Start-Date: 2011-03-28 18:41:10
Install: linux-headers-2.6.32-30 (2.6.32-30.59), linux-image-2.6.32-30-generic (2.6.32-30.59), linux-headers-2.6.32-30-generic (2.6.32-30.59)
Upgrade: linux-headers-generic (2.6.32.29.35, 2.6.32.30.36), xulrunner-1.9.2 (1.9.2.15+build1+nobinonly-0ubuntu0.10.04.1, 1.9.2.16+build1+nobinonly-0ubuntu0.10.04.1), libdbus-1-3 (1.2.16-2ubuntu4.1, 1.2.16-2ubuntu4.2), linux-image-generic (2.6.32.29.35, 2.6.32.30.36), gnome-screensaver (2.30.0-0ubuntu2, 2.30.0-0ubuntu2.1), linux-libc-dev (2.6.32-29.58, 2.6.32-30.59), openssh-client (5.3p1-3ubuntu5, 5.3p1-3ubuntu6), dbus (1.2.16-2ubuntu4.1, 1.2.16-2ubuntu4.2), linux-image (2.6.32.29.35, 2.6.32.30.36), libdbus-1-dev (1.2.16-2ubuntu4.1, 1.2.16-2ubuntu4.2), flashplugin-installer (10.2.152.27ubuntu0.10.04.1, 10.2.153.1ubuntu0.10.04.1), linux-source (2.6.32.29.35, 2.6.32.30.36), ssh (5.3p1-3ubuntu5, 5.3p1-3ubuntu6), dbus-x11 (1.2.16-2ubuntu4.1, 1.2.16-2ubuntu4.2), openssh-server (5.3p1-3ubuntu5, 5.3p1-3ubuntu6), linux-source-2.6.32 (2.6.32-29.58, 2.6.32-30.59), ssh-askpass-gnome (5.3p1-3ubuntu5, 5.3p1-3ubuntu6)
End-Date: 2011-03-28 18:43:53

Start-Date: 2011-03-28 19:05:06
Remove: linux-headers-2.6.32-29 (2.6.32-29.58), linux-headers-2.6.32-29-generic (2.6.32-29.58), linux-image-2.6.32-29-generic (2.6.32-29.58)
End-Date: 2011-03-28 19:05:25

Start-Date: 2011-03-31 12:22:53
Upgrade: language-pack-en-base (10.04+20110204, 10.04+20110204+mfs1), language-pack-ru-base (10.04+20100714, 10.04+20110204+mfs1), gdm (2.30.2.is.2.30.0-0ubuntu5, 2.30.2.is.2.30.0-0ubuntu5.1), language-pack-en (10.04+20110204, 10.04+20110204+mfs1), language-pack-ru (10.04+20100714, 10.04+20110204+mfs1)
End-Date: 2011-03-31 12:23:42

Start-Date: 2011-03-31 20:04:59
Upgrade: libldap-2.4-2 (2.4.21-0ubuntu5.3, 2.4.21-0ubuntu5.4)
End-Date: 2011-03-31 20:05:09
Kidinnu 05.04.2011 13:49 #
Мне помогла смена темы c Clearlooks на, например, BBStyle. (Debian)
pozadi 05.04.2011 14:25 #
Тоже помогло, но наверное просто тема "полегче" меньше тормозит.
И хочется поставить другую тему (у меня только на "Мгле" нормально работает).
Dem0n3D 05.04.2011 14:11 #
Дрова пробовал переустанавливать на видяху? Или со старым ядром грузиться?
pozadi 05.04.2011 14:20 #
пробовал
gardarea51 05.04.2011 14:55 #
А может у вас IOWAIT шалит? То есть ожидание ответа от дисковой подсистемы, но вы бы услышали характерный шорох жесткого..
pozadi 05.04.2011 15:06 #
Звука вроде нет, да и зачем нужен диск при двигании курсора по списку меню, например?
xel 05.04.2011 16:36 #
Багу подтверждаю
На vesa,кстати, всё нормально. на nouveau не пробовал
может это как-то связано с cairo? Cleanlooks тоже через него рисует?
Lemures 05.04.2011 20:10 #
А если удалить фф4 и все притянутые им пакеты, к норме возвращается?
ZED 06.04.2011 19:48 #
Во-первых на лоре отмечали что с последними версиями блоба ускорение ФФ4 или минимальное или вовсе отсутствует
Во-вторых я до сих сижу на 195.36.24 именно потому, что в более новых дровах много починили, но еще больше поломали. Например после выхода из ждущего режима иксы начинает колбасить при манипуляциях с окном плеера (там vdpau, а системе компиз), система впадает в полный ступор. Я предполагаю, что это может в какой то мере быть и актуально для вас. Однако я бы и вовсе испускал лучи радости, но моя версия на новых ядрах (38 особенно) не собирается. Однако по совокупности багов, мне удобнее сидеть на старом ядре без волшебного патча на 200 строк, чем на новом блобе с такими жуткими лагами.