divius 10.05.2010 21:36

Мой PPAQt 4.7.0 beta1 для Ubuntu Lucid

Любителям экстрима предлагается возможно первый репозиторий разрабатываемой версии Qt - 4.7.0 (beta 1).

Предупреждаю, что пакет экспериментальный, могут быть глюки не только с самой нестабильной версией, но и с тем, как я её упаковал. Рекомендуется для применения ТОЛЬКО при выполнении одного из условий:
1. Пакеты устанавливаются на виртуальную машину
2. Ваш DE - НЕ KDE, то есть если Qt накроется, хоть что-то у вас работать будет
3. Вы отчаяный экстремал и ничего не боитесь=)
Так или иначе, перед установкой советую запастись утилитой ppa-purge.

Замечания:
Мистическим образом исчезло всё, что связано с устаревшим assistant: больше нет libqt4-assistant, утилиты assistant_adp. С новым assistant всё должно быть в порядке
Из-за этого пакеты конфликтуют, например, с python-qt4
Присутствует пакет libqt4-mediaservices, но, судя по последним новостям, в релиз он не войдёт
Утилита qml находится в новом пакете qt4-qml, там же лежат и файлы импорта для него. Модуль QtDeclarative лежит в пакете libqt4-declarative

Пакеты брать отсюда: https://launchpad.net/~divius/+archive/extreme

О всех проблемах просьба сообщать.
Удачи.


Тэги: ppa qt4 ubuntu
+ 4 -
Похожие Поделиться

chemikadze 11.05.2010 00:59 #
О, как раз об этом недавно задумывался: вот выйдет Qt 4.7. Будет ли бинарная совместимость между 4.6 и 4.7, или пользователи бубунты как всегда в пролете?
divius 11.05.2010 09:24 #
Должна быть, по крайней мере. Всегда была
Murz 12.05.2010 17:37 #
А какие заметные преимущества я получу от использования Qt 4.7.0? Ну, разумеется, кроме пачки новых глюков ;)
Насколько я понимаю, старые программы ничего нового от увеличения версии Qt не приобретут?
divius 12.05.2010 19:37 #
Обещается улучшение производительности.
Murz 12.05.2010 17:38 #
За утилиту ppa-purge, спасибо - не знал о существовании такой.
Только вот она просто всего лишь удаляет строчку с этим PPA, насколько я понял.

А хотелось бы более сложных действий - подчистить и пакетики, которые с этого PPA ставились и заменить их на версии из репозитория. Пока так и не нашёл способа как это можно сделать не вспоминая вручную что оттуда ставилось, удаляя и ставля заново с официального репозитория... Может кто подскажет метод?
divius 12.05.2010 19:36 #
Это утилита как раз чистит пакеты!
Murz 13.05.2010 11:23 #
О, супер! Не думал что скриптик в 4 кбайта включает в себя этот функционал! Побежал ставить ;)

А для этого ppa-purge есть официальный ppa? Чтобы не вручную следить за обновлениями...
А то по ссылке из статьи он скачивается с https://launchpad.net/~xorg-edgers/+archive/ppa у которого кроме ppa-purge ещё куча всяких ненужных пакетов, которые мне не хотелось бы постоянно тянуть оттуда ;(
Murz 13.05.2010 11:25 #
Или может как-то можно подключить PPA чтобы система при обновлениях с него тянула только нужные мне пакеты, а не всё что там есть?
divius 13.05.2010 12:15 #
Довольно сложно, насколько я знаю, проще создать свой ppa и скопировать туда пакет