beep 17.12.2010 09:05

Есть проблема!Не могу поставить phpmyadmin

Запускаю установку, получаю фигушки:

debian:/var/www# apt-get install phpmyadmin
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
phpmyadmin: Зависит: php5-mcrypt но он не будет установлен или
php4-mcrypt но он не может быть установлен
E: Сломанные пакеты
debian:/var/www#


Пробую доставить php5-mcrypt и снова фигушки:

debian:/var/www# apt-get install php5-mcrypt
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
php5-mcrypt: Зависит: libmcrypt4 но он не может быть установлен
E: Сломанные пакеты


Впервые столкнулся с подобной проблемой, куда ковырять, даже не представляю.


Тэги: debian phpmyadmin проблема
+ 0 -
Похожие Поделиться

rb 17.12.2010 09:31 #
В Убунту из Universe репозиториев проблем нет:

$ apt-cache show php5-mcrypt
Package: php5-mcrypt
Priority: optional
Section: universe/web
Installed-Size: 104
Maintainer: Ubuntu MOTU Developers
Original-Maintainer: Debian PHP Maintainers
Architecture: i386
Source: php-mcrypt
Version: 5.3.2-0ubuntu1
Depends: libc6 (>= 2.4), libmcrypt4, phpapi-20090626+lfs
Filename: pool/universe/p/php-mcrypt/php5-mcrypt_5.3.2-0ubuntu1_i386.deb
Size: 15174
MD5sum: 2aa87b628d32b3c591e6ee1d9cc8c456
SHA1: efcaa9e01ae02fa7783876322eb3b3911a7cfa6f
SHA256: 0f7a888f5d154091c76e0487c27e40322f1248d065f028f0ddf035e9074fa3cb
Description: MCrypt module for php5
This package provides a module for MCrypt functions in PHP scripts.
.
PHP5 is an HTML-embedded scripting language. Much of its syntax is borrowed
from C, Java and Perl with a couple of unique PHP-specific features thrown
in. The goal of the language is to allow web developers to write
dynamically generated pages quickly.
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

Не знаю, как там в Дебиане (в смысле насколько Убунту Дебиан), но может тоже есть разные типы репозиториев и тебя куда-то не туда занесло?
cppmm 17.12.2010 10:05 #
В debian'е всё отлично(поэтому и в убунте проблем нет).
Здесь проблема не в дистрибутиве.
beep 17.12.2010 09:35 #
Да в том-то и дело, что ставлю в принципе по одному сценарию и никогда такой ошибки не возникало.
rb 17.12.2010 09:39 #
Значит погугли этот пакет в .deb виде, скачай и установи вручную. Ну или из исходников. Больше ничего в голову не приходит.
danik 17.12.2010 09:55 #
Версии зависимостей проверял с версией PHP?
Попробуй следующее:
$ sudo aptitude why phpmyadmin
$ sudo aptitude why-not phpmyadmin
$ sudo apt-get install phpmyadmin -o Debug::pkgProblemResolver=true
cppmm 17.12.2010 10:09 #
Только без sudo и из-под рута. Это не убунта, здесь по умолчанию этого костыля нет.
cppmm 17.12.2010 10:03 #
Версия дистрибутива?
Что в sources.list?
Ставились ли какие-нибудь пакеты вручную?
Давно ли делались апдейты и/или апгрейды системы?
Что предшествовало ошибке?
Какие действия с вашей стороны были предприняты для решения проблемы?
Пробовали ли принудительно фиксить пакеты? Если да, каков результат?

Что же вытягивать-то всё надо?
Всем было бы проще, если бы задающие вопрос осиливали вот эту доку!!!!111

Пока что можно говорить только в слепую, потому что нет никаких данных, но скорее всего это либо криво были добавлены разные репы, либо криво установлен какой-нибудь пакет в обход основного репозитария.
thebeetlebum 17.12.2010 10:10 #
Один я всегда его ставлю вручную, скачивая с офф сайта последнюю версию и прописывая в виртуалные хосты апача?( Как-то удобней, надежней. А вообще в последнее время я пользуюсь sqlbuddy. Это конечно не такой гигант, но для большинства мелких задач хватает за глаза.
cppmm 17.12.2010 10:17 #
скачивая с офф сайта последнюю версию и прописывая в виртуалные хосты апача?( Как-то удобней, надежней.

Спорное утверждение и по поводу удобства, и по поводу надёжности. Я бы не рекомендовал. Особенно в свете постоянных выкрутасов с версиями в php.
thebeetlebum 17.12.2010 10:34 #
Тогда можете вспомнить что было недавно, когда все хостеры впсок и дедиков выслали предупреждения о дырке. Людей с новыми версиями это не затронуло. Я понимаю, стабильность, все такое. Ну ладно, будем считать я один такой мазохист и мне просто повезло
cppmm 17.12.2010 10:51 #
Именно для таких случаев существуют секурные апдейты. И в debian'е в 99-ти процентах случаев они успевают до опубликования дыры(портируются сразу после появления соответсвующего багфикса). С новыми же, неоттестированными версиями вероятность нарваться на незакрытую дыру значительно больше. Вплоть до того, что иногда приходится откатываться назад(как было, к примеру, у меня на одном из подконтрольных FreeBSD-серверов с OpenSSL несколько лет назад). Понятие стабильности как раз и включает в себя среди прочего безопасность. Именно поэтому зачастую для серверов выбирают Debian, RedHat и другие "отмороженные" дистрибутивы.
DobrijZmej 17.12.2010 10:15 #
ну, лично я стараюсь ставить из Синаптика - он тогда показывает, почему именно не может установить.
Обычно установлена не та версия библиотеки - тогда Синаптик показывает, какая версия нужна, а какая версия установлена или есть в репозитории.
thebeetlebum 17.12.2010 10:34 #
Вы всегда на сервер синаптик ставите?
beep 17.12.2010 11:44 #
Debian установлен только вчера, ещё не обновлял, трафик по 2 рубля, разорюсь.
Linux debian 2.6.26-1-686 #1 SMP Sat Jan 10 18:29:31 UTC 2009 i686 GNU/Linux
Но завтра на работе похоже что придется.

Весь софт всегда ставил из под apt.
Мой source.list
deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib

deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib

# Yandex
deb http://repo.yandex.ru/debian lenny main non-free
mikle 17.12.2010 12:21 #
Похоже на то, что phpmyadmin имеет зависимости от версий пакетов отличающихся от установленных. Скорее всего обновление решит проблему.
xT 17.12.2010 13:30 #
Ребят, не майтесь дурью
libmcrypt4 лежит в ветке contrib, которая не подключена у комрада
cppmm 17.12.2010 18:40 #
Нет, он в main.
cppmm 17.12.2010 18:47 #
Нужно делайть update и upgrade.
Судя по выводу uname у вас совершенно устаревший lenny, установленный то ли с самых первых дисков(500), то ли вообще с тех времён, когда он был тестингом. Ужа давно версия ядра в lenny - 2.6.26-2-686.
Соответсвенно и с другими пакетами скорее всего аналогичная ситуация. Вы пытаетесь поставить то, чего уже нет из-за различий версий.
cppmm 17.12.2010 18:48 #
Да. contrib всё-таки стоит подключить. Это xT правильно заметил.
mrkot 17.12.2010 12:27 #
Попробуй apt-get install -f и dpkg-reconfigure --force
a_tronic 17.12.2010 17:35 #
Мб я что-то путаю, но aptitude прекрасно исправляет проблему с зависимостями...
Так что советую попробовать...
kikaha 17.12.2010 21:10 #
http://www.chive-project.com/Features - как альтернатива, не?
beep 19.12.2010 13:26 #
Парни, дело было в обновлении системы.
После apt-get upgrade всё встало на свои места.
Жаль, что часто обновляться не получается :(

cppmm вы правы, с самого первого диска ставил систему