Online video hd

Смотреть домашний видео

Официальный сайт janmille 24/7/365

Смотреть видео бесплатно

Alx 10.04.2011 06:46

Я рекомендуюПолезности для современного ПК с Debian или Ubuntu

После обновления железа на десктопном компьютере, многие задумываются, как бы улучшить производительность системы. Если железо уже обновлено, то остаётся программное обеспечение.

Всем известно что стандартные ядра дистрибутивов не очень шустро работают на новом железе. Но есть проект Zen-Kernel, выпускающий набор патчей ядра для увеличения отзывчивости и производительности десктопных систем. Я думаю, что и многие знают о замечательном ядре для Debian и Ubuntu - Liquorix, собранном с Zen-патчами и позволяющим улучшить отклик интерфейса. Недавно с ним была замечена одна проблема на Ubuntu 10.04: пакет linux-headers-2.6.38-2.dmz.1-liquorix-686 при обновлении не устанавливался из-за зависимости от gcc-4.5, которого в Ubuntu 10.04 нет. Исправляется это обновлением gcc из ppa:ubuntu-toolchain/test, после которого можно снова попробовать обновить linux-headers.

Но не всё так с Liquorix хорошо: драйвера Nvidia из репозиториев Ubuntu не устанавливаются с этим ядром, так же нет поддержки PAE, что особенно огорчает. Что же тогда делать владельцам современных компьютеров с видеокартами Nvidia и большим (от 4ГБ) объёмом оперативной памяти? Мириться с vesa и 3.25ГБ памяти вместо четырёх, шести, восьми гигабайт? Мною был найден выход.

Есть такой чувак Kendall Weaver, который собирает ядро для Ubuntu-подобного дистрибутива Peppermint. И это ядро - тот самый Liquorix с включённым PAE. Чтобы его установить, нужно добавить репозиторий ppa:kendalltweaver/testing (keyring) и обновить оттуда linux-image и linux-headers. После обновления ядра этот репозиторий рекомендуется отключить, так как оттуда будут хотеть обновиться и другие пакеты. Так же можно обратить внимание на проект AV Linux. В этом дистрибутиве для создателей мультимедийного контента тоже используется ядро Liquorix с PAE. Только собирает его уже другой человек из AV Linux.

С ядром вроде разобрались, теперь на счёт драйвера Nvidia. Существует интересный скриптик sgfxi, умный установщик видео-драйверов для дистрибутивов Debian, Ubuntu и Arch. Он сам определяет видеокарту и требуемый для неё драйвер, а затем скачивает его и устанавливает приемлемым для дистра способом. Прежде всего, нужно удалить из системы драйвера, установленные из репозитория Ubuntu. Затем, установить этот скрпит:

1
# cd /usr/local/bin && wget http://smxi.org/smxi.zip && unzip smxi.zip && rm -f smxi.zip


Перед запуском sgfxi, необходимо выключить графический сервер X (/etc/init.d/gdm stop) или хотя бы перейти в виртуальный терминал, войти под root-ом, запустить sgfxi и он сам попробует остановить иксы.

После всех этих операций мы имеем отзывчивую систему с самыми новыми видео-драйверами и полным объёмом памяти.


Тэги:
+ 6 -
Похожие Поделиться

exelens 10.04.2011 11:12 #
+ 1 -
Походу штука модная.
Но геморная...
PaulRed 10.04.2011 11:16 #
+ 4 -
1. Использовал в дебиане долгое время ядро от liquorix, но с выходом 2.6.38 разница в производительности пропала вообще и теперь использую дистрибутивное ядро.
2. Можно установить драйвер стандартным нвидиевским инсталлятором, sgfxi не обязателен.
3. sgfxi сам отключает X, нет необходимости делать это вручную.
Выбор за вами конечно, но я считаю, что этот проект не нужен, ибо нет никакой разницы в производительности с 38-м ядром и куча лишних телодвижений.
Alx 10.04.2011 11:41 #
+ -1 -
1. надо бы попробовать 38-ое ядро
2. не спорю, можно.. я и раньше так делал, но sgfxi удобен тем, что позволяет из консоли проверить наличие новых драйверов, так же он сам создаёт xorg.conf с разными фиксами под определённый драйвер
3. я об этом написал
ну если бы ядра чаще обновлялись.. а то в 10.04 ещё 32-ое ядро, когда на время загрузился с ним, то удивился очень сильной разнице в отзывчивости системы, относильно 38-го liquorix
ZED 10.04.2011 14:50 #
+ -1 -
с выходом 2.6.38 разница в производительности пропала вообще

а BFQ уже отменили?
Dark_SS 10.04.2011 11:22 #
+ 1 -
Но не всё так с Liquorix хорошо: драйвера Nvidia из репозиториев Ubuntu не устанавливаются с этим ядром
У меня установился в 10.10
Вот два ppa с ядрами, которые я пробовал. В первом только один патч, и оно заменяет стандартное ядро - просто обновляемся и пробуем. Во втором полный набор патчей от того самого анестезиолога, ставится отдельными файлами (как именно - читаем по ссылке), я сижу на нём, всё нормально (фпс выросли в 1,5 раза), кроме виртуалбокса =(
Alx 10.04.2011 11:45 #
+ -1 -
интересно.. Не слышался об этих ядрах. В Zen, кстати, не только патчи от анестезиолога, но и куча других, например, с ними у меня система стала нормально засыпать и просыпаться
Dark_SS 10.04.2011 11:54 #
+ -1 -
Про Zen знаю, читал, ставил, у меня с ним частота процессора не сбрасывается при низкой загрузке.
Shtsh 10.04.2011 11:43 #
+ 4 -
Можно узнать, почему на компьютере с большим объёмом ОЗУ используется дистрибутив под i686? Неужели нету поддержки amd64?
Alx 10.04.2011 11:58 #
+ -5 -
До сих пор везде советуют ставить 32, да и я как то к этому склоняюсь, когда 64 допилят, может быть и перейду, а сейчас помогает PAE, большего пока и не надо.
Shtsh 10.04.2011 13:08 #
+ 1 -
Пардон, а везде это где? И чего недопиленного в amd64?
deep 10.04.2011 13:48 #
+ -3 -
FlashPlayer например, плагина дебаг нет, а мне очень надо по работе.
Shtsh 10.04.2011 14:05 #
+ -1 -
Ага, дебагер для флешплеер, такая распространённая и неспецифическая штука, что у Alx и у тебя совпали причины.
Alx 10.04.2011 14:12 #
+ -1 -
у меня причина не в этом =) я просто не переставляю систему каждый месяц
Alx 10.04.2011 15:38 #
+ 0 -
а что, надо переставлять? =) тут все виндузятники чтоли сидят?
deep 10.04.2011 17:06 #
+ 0 -
Набежали флеша ненавистники и заминусовали :) Гениально! Я ответил на вопрос чего нет допиленного в amd64 и объяснил почему мне это надо.
Alx 10.04.2011 13:57 #
+ -4 -
в интернете.. я прислушиваюсь ко мнению людей. даже на сайте убунту 32 помечена как рекомендуемая. и не хочется свою систему сносить и так резко всё менять. а почему вы меня так сильно убеждаете перейти на 64? я пользуюсь тем, что мне нравится, у меня нет убеждений никаких, просто с 32 я проблем никаких не испытываю.. да и что так прям всё и поменяется в лучшую сторону, если перейду на 64?
Shtsh 10.04.2011 14:03 #
+ 0 -
Мой вопрос будет риторическим, но, если есть желание, ответьте:
Почему некоторые люди при заданных простых логичных вопросах сразу считают, что кто-то на них сразу "наезжает" и в чём-то убеждает или ругает?

Мне абсолютно без разницы, что вы выбрали для себя, зато интересно узнать, почему был сделан этот выбор.
Alx 10.04.2011 14:09 #
+ -4 -
потому что вы очень настойчиво об этом говорите и у меня сложилось такое впечатление =)
у меня вся система 32 бита и ставил я её не вчера, так зачем мне туда ставить ядро на 64? к тому же, когда я устанавливал её, у меня был процессор, который поддерживал только 32-битные инструкции. конечно, когда нибудь я захочу переставить систему и тогда скорее всего выберу 64.
кстати встречал людей, которые всё ещё не хотят использовать 64-битные системы, просто так или из-за страха какого-то.. хз
Alx 10.04.2011 15:37 #
+ -4 -
и за что же такая оценка моему комментарию? лучше бы поставили минус человеку, начавшему холивар.
Shtsh 10.04.2011 15:50 #
+ 1 -
Да, давайте, минусуйте :3
ZED 10.04.2011 15:13 #
+ -3 -
везде советуют ставить 32

Везде как раз советуют 64. В куче софта есть специфические функции только для 64-битных ОС. Мак ось по дефолту уже ставится 64, винда 8 будет только 64, сейчас на винде 64 вирусы почти не работают, в линуксе весь софт уже лет 5 есть под 64, редкие программы можно запустить с 32-битными либами, браузер получает от 64 бит очень серьезную прибавку к скорости, уже не говоря о компиляции софта под последние инструкции процов

когда 64 допилят, может быть и перейду

ну еще лет через 20 и линукс может допилят, а пока купи макбук и не ной

помогает PAE

первым 2м поросятам из сказки домики из гамна тоже помогали некоторое время, а 3й поросенок сразу делал дом основательно и капитально, без костылей. в курсе чем сказка кончилась?
Alx 10.04.2011 15:34 #
+ 1 -
я вообще то не ныл. следите за выражениями и ваше мнение оставьте при себе а не давите им. я решаю сам что мне использовать в качестве инструмента. сказка вообще с этим никак не вяжется. очень тупо было приводить такой пример. система работает надёжно и шансы на её падение даже меньше чем на 64 битах.
ZED 10.04.2011 16:09 #
+ -9 -
следите за выражениями

галлюцинации?

ваше мнение оставьте при себе

рот затыкаете? прэлэстно! понимаю, весна, гормоны, децкие обиды... только не тащите их в интернет.

я решаю сам

да можете хоть DOS установить, мне то фиолетово, но вот не люблю когда несут откровенную чушь

очень тупо было приводить такой пример

очень тупо городить костыли типа PAE в системе, от которой требуется надежность и стабильность

шансы на её падение даже меньше чем на 64 битах

вероятность сбоя программы не зависит от битности ОС при условии отсутствия в ней костылей и иных ошибок, но ваши бурные фантазии меня радуют
Alx 10.04.2011 16:15 #
+ -7 -
а вы не знали что не все кодеры грамотные и могут при переносе своей программы на 64 наделать ошибок? если фиолетово, так не трындели бы про то что я использую такую хуйню, по вашему, как 32-битную систему.
ZED 10.04.2011 16:19 #
+ -8 -
бред перерастающий в мат это феерично!
Alx 10.04.2011 16:24 #
+ -5 -
где тут бред? ты разве сам не сказал что 32-битная система сравнима с домиком из гавна? по-моему это ты тут бредишь
ZED 10.04.2011 16:30 #
+ -6 -
я говорил про PAE, а по остальным пунктам проконсультируйтесь с вашим психиатром, я бессилен
exelens 10.04.2011 20:12 #
+ 3 -
Не материмся.
Спорить спорьте.
kma21 10.04.2011 12:12 #
+ 0 -
Вообще, при большом желании, можно ведь пересобрать это самое Zen-kernel и включить всЁ, что надо.
И ещЁ. Я пользую на десктопе со времЁн его появления (позапрошлой зимой) 64-bit дистрибутивы и проблем не знаю. Так что если уж нет веских причин (например, есть 32-bit софтина, которая не работает под 64-bit), а только абстрактные "а может быть", то ставьте 64-bit дистрибутивы =)
Alx 10.04.2011 14:02 #
+ 0 -
можно конечно и пересобрать, но не хочется. мне компьютер для работы нужен, а для сборок у меня есть сервер с Gentoo =)
почему вы там за меня беспокоитесь? я привык к 32 и нормально с этим работаю. мне его полностью достаточно. почему я должен переходить на 64? у вас работает нормально 64 - ну и хорошо, я рад за вас. а у меня нормально работает 32 и меня всё устраивает.
kma21 10.04.2011 17:41 #
+ 1 -
А кто сказал, что Вы кому-то что-то должны? Я лично даже не намекал на это. И я за Вас вовсе ни капли не беспокоюсь, я прст констатировал факт того, что нынче 64-bit версии дистрибутивов отлично работают.
Nikisch 10.04.2011 19:07 #
+ 1 -
По опыту, с х64 проблем было больше (около года назад ставил последний раз). памяти жрется много больше, работает не быстрее, не все софтины есть, стабильность и совместимость ниже. У меня на всех компах по 2 гига памяти, т к больше не нужно.
На ноуте мне нужна скорость (т к проц слабый) и автономка. Ну и все функции (оборудование и т п) должны работать. Что мне дадут эти х64 бита?

PS^ давате чуть более конструктивно, нефанатичные мои. Тред выше ужасает =)
Alx 10.04.2011 19:26 #
+ -3 -
вы адекватны
ZED 11.04.2011 02:21 #
+ -1 -
2 гига... работает медленно... больше не нужно...

facepalm
Nikisch 12.04.2011 19:38 #
+ 2 -
Можно подумать, что еще несколько гигов пустующей памяти мне компенсируют 1Ггц проц. =)
ZED 10.04.2011 15:02 #
+ 0 -
драйвера Nvidia из репозиториев Ubuntu не устанавливаются с этим ядром

Старые не устанавливаюца, новые - легко.
Alx 10.04.2011 15:35 #
+ -4 -
я и писал что новые надо ставить и предложил удобную утилиту для этого.
ZED 10.04.2011 15:59 #
+ 0 -
так новые и ставятся нормально без всяких утилит, нафига костыли городить. x-swat ppa знаете? для дебиана тоже репы где-то были.
Alx 10.04.2011 16:01 #
+ -4 -
костыли? о чём вы?
ZED 10.04.2011 16:11 #
+ 0 -
вы ваще в курсе что драйверы могут устанавливаться и обновляться через репозитории?
Alx 10.04.2011 16:18 #
+ -5 -
ага, знаю, в репозитории ubuntu 10.04 есть драйвера nvidia-173 и nvidia-current, которые не поставились на особое ядро
ZED 10.04.2011 16:24 #
+ -1 -
ты идиот? там 195.хх, а ты "писал что новые надо ставить", так новые в PPA и собираются нормально!
Alx 10.04.2011 16:32 #
+ -3 -
переходить на личные оскорбления.. остроумно. nvidia-current это 185. sgfxi ставит 260 с сайта nvidia. и что с того что новые в ppa лежат? так напиши про это, расскажи людям что sgfxi - плохо, а твой ppa - хорошо.
Alx 10.04.2011 16:47 #
+ -3 -
на сколько они там новые? хз. если б нормально сказал, можно было бы и в упд добавить
SergMarkov 10.04.2011 16:00 #
+ 0 -
Проще самому скомпилировать ядро, чем лазить по всяким свалкам
Alx 10.04.2011 16:02 #
+ -4 -
компилируйте! флаг вам в руки =)
SergMarkov 10.04.2011 16:49 #
+ 2 -
Какие то проблемы наложить патчи от коливаса и взять стандартный конфиг?:-) Все это делается за минуту, еще сколько оно компилируется. Хотите вдобавок к этому потыкать в menuconfig, за ради бога :-)
Alx 10.04.2011 16:55 #
+ -2 -
репозитории это не свалки, за софтом там следят неслабо, так как есть система отчётов об ошибках. я, к сожалению, не знаю совместимы ли те патчи с патчами от убунты.. а в ванильном ядре могут не быть какие нибудь специфичные для убунты драйверы
SergMarkov 10.04.2011 17:14 #
+ 2 -
Да причем тут ванильное ядро, в любом дистре есть пакет с сорцами своего ядра. Накладывайте нужные патчи, патчи коливаса практически ко всем подходят, и вперед с песней :-)
SergMarkov 10.04.2011 16:53 #
+ 0 -
сколько то.. естественно:-) )
Shtsh 10.04.2011 16:14 #
+ 2 -
Ну, вот, из-за какой-то фигни снёс интересную многим инфу
Shtsh 10.04.2011 16:15 #
+ 1 -
Кэш всё помнит.

После обновления железа на десктопном компьютере, многие задумываются, как бы улучшить производительность системы. Если железо уже обновлено, то остаётся программное обеспечение.

Всем известно что стандартные ядра дистрибутивов не очень шустро работают на новом железе. Но есть проект Zen-Kernel, выпускающий набор патчей ядра для увеличения отзывчивости и производительности десктопных систем. Я думаю, что и многие знают о замечательном ядре для Debian и Ubuntu - Liquorix, собранном с Zen-патчами и позволяющим улучшить отклик интерфейса. Недавно с ним была замечена одна проблема на Ubuntu 10.04: пакет linux-headers-2.6.38-2.dmz.1-liquorix-686 при обновлении не устанавливался из-за зависимости от gcc-4.5, которого в Ubuntu 10.04 нет. Исправляется это обновлением gcc из ppa:ubuntu-toolchain/test, после которого можно снова попробовать обновить linux-headers.

Но не всё так с Liquorix хорошо: драйвера Nvidia из репозиториев Ubuntu не устанавливаются с этим ядром, так же нет поддержки PAE, что особенно огорчает. Что же тогда делать владельцам современных компьютеров с видеокартами Nvidia и большим (от 4ГБ) объёмом оперативной памяти? Мириться с vesa и 3.25ГБ памяти вместо четырёх, шести, восьми гигабайт? Мною был найден выход.

Есть такой чувак Kendall Weaver, который собирает ядро для Ubuntu-подобного дистрибутива Peppermint. И это ядро - тот самый Liquorix с включённым PAE. Чтобы его установить, нужно добавить репозиторий ppa:kendalltweaver/testing (keyring) и обновить оттуда linux-image и linux-headers. После обновления ядра этот репозиторий рекомендуется отключить, так как оттуда будут хотеть обновиться и другие пакеты. Так же можно обратить внимание на проект AV Linux. В этом дистрибутиве для создателей мультимедийного контента тоже используется ядро Liquorix с PAE. Только собирает его уже другой человек из AV Linux.

С ядром вроде разобрались, теперь на счёт драйвера Nvidia. Существует интересный скриптик sgfxi, умный установщик видео-драйверов для дистрибутивов Debian, Ubuntu и Arch. Он сам определяет видеокарту и требуемый для неё драйвер, а затем скачивает его и устанавливает приемлемым для дистра способом. Прежде всего, нужно удалить из системы драйвера, установленные из репозитория Ubuntu. Затем, установить этот скрпит:

# cd /usr/local/bin && wget http://smxi.org/smxi.zip && unzip smxi.zip && rm -f smxi.zip

Перед запуском sgfxi, необходимо выключить графический сервер X (/etc/init.d/gdm stop) или хотя бы перейти в виртуальный терминал, войти под root-ом, запустить sgfxi и он сам попробует остановить иксы.

После всех этих операций мы имеем отзывчивую систему с самыми новыми видео-драйверами и полным объёмом памяти.
ZED 10.04.2011 16:17 #
+ 1 -
спасибо
ZED 10.04.2011 16:27 #
+ 1 -
бугога, твой пост кто-то минусанул, я даже догадываюсь кто... ржунимагу...
Anrock 10.04.2011 16:44 #
+ 0 -
А zen kernel умеет в гибернацию?
Shtsh 10.04.2011 16:47 #
+ 1 -
Говорят, умеет, но автор этого — Alx, поэтому вопросы к нему.

Я лишь спас информации от потери.
Alx 10.04.2011 16:50 #
+ -6 -
да ты герой.. а ведь удалил из-за тебя. выводят такие личности, которых всё не устраивает, лишь бы что-нибудь против сказать - это и есть ваш смысл жизни
Shtsh 10.04.2011 17:02 #
+ 1 -
спасибо за то, что открыл мне глаза.
Alx 10.04.2011 16:52 #
+ -1 -
умеет. в zen kernel есть tuxonice
Anrock 10.04.2011 16:54 #
+ 0 -
Вот только TuxOnIce уже .37, а zen только .36, хотя ядро аж .38 уже. Но все равно, как-нибудь попробую, спасибо.
Alx 10.04.2011 16:59 #
+ -3 -
вот есть новая, наверно ещё тестируемая, версия http://git.zen-kernel.org/zen-stable/snapshot/zen-stable-2.6.38.2.tar.bz2
ZED 10.04.2011 16:55 #
+ 1 -
давно сижу на нем, все умеет
ZED 10.04.2011 16:15 #
+ -1 -
Пусть тут будет это =)

мужык, у тебя ваще седня какое то обострение что ли? получил плюсов, отминусовал всех кто несогласен и удалил пост, охренеть... могу одолжить 25 центов, там кнопочка есть, тебе должно полегчать.

В хорошем качестве hd видео

Онлайн видео бесплатно


Смотреть русское с разговорами видео

Online video HD

Видео скачать на телефон

Русские фильмы бесплатно

Full HD video online

Смотреть видео онлайн

Смотреть HD видео бесплатно

School смотреть онлайн